<!DOCTYPE html><html><head><meta charSet="utf-8" class="next-head"/><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" class="next-head"/><meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no" class="next-head"/><meta name="google-site-verification" content="NXbTi7gyLQESV4NIskeE9Ka0Am8KjAtzg5gm8g38HbU" class="next-head"/><meta name="keywords" content="python cheat sheet" class="next-head"/><meta name="description" content="This handy one-page reference presents the Python basics that you need to do data science" class="next-head"/><title class="next-head">Python For Data Science - A Cheat Sheet For Beginners - DataCamp</title><link rel="canonical" href="https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" class="next-head"/><link rel="author" href="https://plus.google.com/u/0/+Datacamp/" class="next-head"/><link rel="shortcut icon" type="image/x-icon" href="https://cdn.datacamp.com/main-app/assets/favicon-335cd0394b32102a39221d79e5fd7e51078e6d32a0c8aea59676a6869f84e9d8.ico" class="next-head"/><link rel="chrome-webstore-item" href="https://chrome.google.com/webstore/detail/lbbhbkehmgbndgfdbncbmikooblghdbi" class="next-head"/><meta property="og:title" content="Python For Data Science - A Cheat Sheet For Beginners" class="next-head"/><meta property="og:image" content="https://cdn.datacamp.com/community/logos/medium/placeholder.jpg" class="next-head"/><meta property="og:url" content="https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" class="next-head"/><meta property="og:type" content="article" class="next-head"/><meta property="og:published_time" content="2016-10-12T07:26:46.000Z" class="next-head"/><meta property="og:author" content="Karlijn Willems" class="next-head"/><meta property="og:description" content="This handy one-page reference presents the Python basics that you need to do data science" class="next-head"/><meta property="og:site_name" content="DataCamp Community" class="next-head"/><meta name="twitter:title" content="Python For Data Science - A Cheat Sheet For Beginners" class="next-head"/><meta name="twitter:description" content="This handy one-page reference presents the Python basics that you need to do data science" class="next-head"/><meta name="twitter:card" content="summary" class="next-head"/><meta name="twitter:site" content="@DataCamp" class="next-head"/><meta name="twitter:creator" content="@DataCamp" class="next-head"/><meta name="twitter:domain" content="www.datacamp.com" class="next-head"/><meta name="twitter:image" content="https://cdn.datacamp.com/community/logos/medium/placeholder.jpg" class="next-head"/><meta name="twitter:image:width" content="1200" class="next-head"/><meta name="twitter:image:height" content="628" class="next-head"/><meta name="twitter:image:alt" content="Python For Data Science - A Cheat Sheet For Beginners" class="next-head"/><meta name="article:publisher" content="https://www.facebook.com/DataCamp-726282547396228" class="next-head"/><meta name="fb:app_id" content="726282547396228" class="next-head"/><script async="" src="https://promo.datacamp.com/banner.js" class="next-head"></script><script async="" src="https://compliance.datacamp.com/base.js" class="next-head"></script><link rel="preload" href="/community/_next/ae82a1f0-6fdc-4b07-bd86-1be55ffe3c58/page/community/tutorial.js" as="script"/><link rel="preload" href="/community/_next/ae82a1f0-6fdc-4b07-bd86-1be55ffe3c58/page/_error.js" as="script"/><link rel="preload" href="/community/_next/163c3423841a38b05eb7fe05a92d006a/app.js" as="script"/><style id="__jsx-396080995">.Logo.jsx-396080995{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;}
.Logo__image.jsx-396080995{display:block;width:122px;height:28px;margin-left:8px;}
.Logo__image.jsx-396080995 svg{fill:#FFFFFF;}
@media (min-width:800px){.Logo.jsx-396080995{height:59px;}.Logo__image.jsx-396080995{margin:17px auto 0;}}</style><style id="__jsx-499055511">.SidebarMenu.jsx-499055511{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;position:fixed;z-index:300;width:100vw;height:50px;background-image: linear-gradient(207deg, #2388B0, #33AACC);}
.Layout--banner .SidebarMenu.jsx-499055511{top:55px;}
.icon.jsx-499055511{text-align:right;}
.icon.jsx-499055511 svg{margin-right:9px;width:20px;height:20px;fill:#FFFFFF;}
@media (min-width:800px){.SidebarMenu.jsx-499055511{z-index:200;width:220px;top:0;left:0;background-image:none;}.Layout--banner .SidebarMenu.jsx-499055511{top:80px;}}</style><style id="__jsx-2769082546">.Menu.jsx-2769082546{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;margin-top:50px;}
.Layout--banner .Menu.jsx-2769082546{margin-top:105px;}
.Layout--openMenu .Menu.jsx-2769082546{min-height:calc(100vh - 50px - 134px);}
.Layout--openMenu.Layout--banner .Menu.jsx-2769082546{min-height:calc(100vh - 105px - 134px);}
.section.jsx-2769082546{margin-bottom:20px;}
.section.jsx-2769082546 h5.jsx-2769082546{margin:0;padding-left:17px;font-size:13px;-webkit-letter-spacing:3.3px;-moz-letter-spacing:3.3px;-ms-letter-spacing:3.3px;letter-spacing:3.3px;line-height:36px;text-align:left;text-transform:uppercase;background-color:#195B73;color:#7ECCE2;}
.item.jsx-2769082546{margin-bottom:1px;padding-left:12px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-align-content:center;-ms-flex-line-pack:center;align-content:center;font-size:15px;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;line-height:40px;text-decoration:none;color:#FFFFFF;}
.statusIcon.jsx-2769082546{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-align-self:center;-ms-flex-item-align:center;align-self:center;padding:10px;}
.active.jsx-2769082546{background-color:#55AECB;}
a.jsx-2769082546:hover{background-color:#55AECB;}
.image.jsx-2769082546{margin-top:2px;-webkit-flex:0 0 auto;-ms-flex:0 0 auto;flex:0 0 auto;width:30px;height:30px;text-align:center;}
.image.jsx-2769082546 svg{fill:#195B73;}
.active.jsx-2769082546 svg,a.jsx-2769082546:hover svg{fill:#FFFFFF;}
.text.jsx-2769082546{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;}
.subMenu.jsx-2769082546{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;}
@media (min-width:800px){.Menu.jsx-2769082546{position:fixed;width:220px;margin-top:50px;}.Layout--banner .Menu.jsx-2769082546{margin-top:130px;}.section.jsx-2769082546 h5.jsx-2769082546{padding-left:0;text-align:center;}}</style><style id="__jsx-1844558338">.Button.jsx-1844558338{display:-webkit-inline-box;display:-webkit-inline-flex;display:-ms-inline-flexbox;display:inline-flex;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;-webkit-flex:0 0 auto;-ms-flex:0 0 auto;flex:0 0 auto;height:33px;margin:auto 5px;padding:0 15px;font-size:13px;font-weight:bold;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;white-space:nowrap;color:#3A3A3A;border:1px solid transparent;border-radius:4px;background-color:transparent;cursor:pointer;outline:none;}
.Button.jsx-1844558338::before,.Button.jsx-1844558338::after{content:'';-webkit-flex:1 0 auto;-ms-flex:1 0 auto;flex:1 0 auto;}
.icon.jsx-1844558338{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;min-height:20px;}
.icon.jsx-1844558338 svg{-webkit-flex:1 1 0;-ms-flex:1 1 0;flex:1 1 0;height:20px;-webkit-align-self:center;-ms-flex-item-align:center;align-self:center;fill:#33AACC;}
.greyIcon.jsx-1844558338 .icon.jsx-1844558338 svg{min-width:16px;min-height:16px;fill:#3A3A3A;}
.same.jsx-1844558338 .icon.jsx-1844558338{min-width:13px;height:13px;margin-right:5px;}
.same.jsx-1844558338 .icon.jsx-1844558338 svg{height:13px;}
.Button.jsx-1844558338:disabled,.Button.jsx-1844558338:hover.jsx-1844558338:disabled{color:#D1D3D8;background-color:#E6EAEB;}
.primary.jsx-1844558338{background-color:#FFC844;}
.primary.jsx-1844558338:hover{background-color:#FBE28D;}
.secondary.jsx-1844558338{color:#FFFFFF;background-color:#33AACC;}
.secondary.jsx-1844558338:hover{background-color:#7ECCE2;}
.red.jsx-1844558338{color:#FFFFFF;background-color:#FE5C5C;}
.green.jsx-1844558338{height:35px;color:#FFFFFF;background-color:#FFFFFF;}
.green.jsx-1844558338 .icon.jsx-1844558338 svg{fill:#36D57D;width:35px;height:35px;}
.grey.jsx-1844558338{color:#3D4251;background-color:#D1D3D8;}
.grey.jsx-1844558338:hover{color:#3D4251;background-color:#E6EAEB;}
.big.jsx-1844558338{font-size:15px;height:42px;}
.extra.jsx-1844558338{font-size:17px;height:45px;}
.border.jsx-1844558338{border:1px solid #E3E7E8;}
.border.jsx-1844558338:hover{border:1px solid #33AACC;}
.seeAll.jsx-1844558338{border:1px solid #33AACC;}
.seeAll.jsx-1844558338:hover{border:1px solid #FFC844;}
.iconButton.jsx-1844558338:hover{color:#33AACC;}
.minWidth.jsx-1844558338{min-width:85px;}
.noPadding.jsx-1844558338{padding:0;}
@media (min-width:800px){.icon.jsx-1844558338{min-width:13px;height:13px;margin-right:5px;}.icon.jsx-1844558338 svg{height:13px;}.big.jsx-1844558338 .icon.jsx-1844558338{min-width:15px;height:15px;}.big.jsx-1844558338 svg{height:15px;}.extra.jsx-1844558338 .icon.jsx-1844558338,.extraIcon.jsx-1844558338{min-width:17px;height:17px;}.extra.jsx-1844558338 svg,.extraIcon.jsx-1844558338 svg{height:17px;}.green.jsx-1844558338{padding:0 15px;color:#FFFFFF;background-color:#36D57D;}.green.jsx-1844558338 .icon.jsx-1844558338 svg{width:13px;height:13px;fill:#FFFFFF;}.forcePadding.jsx-1844558338{padding:0 15px;}}</style><style id="__jsx-3863678361">.ActionBarSearch.jsx-3863678361{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;-webkit-box-pack:start;-webkit-justify-content:flex-start;-ms-flex-pack:start;justify-content:flex-start;}</style><style id="__jsx-3196442269">.ActionBarAuth.jsx-3196442269{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;-webkit-box-pack:end;-webkit-justify-content:flex-end;-ms-flex-pack:end;justify-content:flex-end;}
.wrapper.jsx-3196442269{display:-webkit-inline-box;display:-webkit-inline-flex;display:-ms-inline-flexbox;display:inline-flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;cursor:pointer;}
.name.jsx-3196442269{margin-right:9px;font-size:13px;font-weight:bold;color:#3D4251;text-decoration:none;}
.name.jsx-3196442269:hover{color:#33AACC;}
.logout.jsx-3196442269{font-size:15px;padding:10px;color:#3D4251;display:inline-block;min-width:100px;}
.logout.jsx-3196442269:hover{background-color:#F0F4F5;border-bottom:solid 1px #E3E7E8;}
.menuList.jsx-3196442269 a.jsx-3196442269{display:block;}</style><style id="__jsx-2159026896">.ActionBar.jsx-2159026896{height:50px;margin-top:50px;padding:0 5px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:justify;-webkit-justify-content:space-between;-ms-flex-pack:justify;justify-content:space-between;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;background-color:#FFFFFF;border-bottom:1px solid #E3E7E8;}
.authBlock.jsx-2159026896{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-fles-direction:row;-ms-fles-direction:row;fles-direction:row;}
.Page.content .ActionBar{margin-bottom:10px;}
@media (min-width:800px){.ActionBar.jsx-2159026896{width:calc(100% - 220px);height:50px;margin-top:0;margin-bottom:0;padding:0 25px;position:fixed;z-index:300;}}</style><style id="__jsx-3889859319">.Title.jsx-3889859319{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;}
.Title.jsx-3889859319 .icon.jsx-3889859319{-webkit-flex:0 0 auto;-ms-flex:0 0 auto;flex:0 0 auto;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;min-width:18px;height:18px;}
.icon.jsx-3889859319 svg{-webkit-flex:1 1 0;-ms-flex:1 1 0;flex:1 1 0;height:18px;-webkit-align-self:center;-ms-flex-item-align:center;align-self:center;fill:#33AACC;}
.Title.jsx-3889859319 .h1.jsx-3889859319,.Title.jsx-3889859319 h1.jsx-3889859319{-webkit-flex:0 0 auto;-ms-flex:0 0 auto;flex:0 0 auto;margin:auto 0 auto 9px;font-size:22px;text-transform:capitalize;}
.Title.jsx-3889859319 .status.jsx-3889859319{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-align-self:center;-ms-flex-item-align:center;align-self:center;padding:10px;}</style><style id="__jsx-1514242801">.TitleBar.jsx-1514242801{height:50px;padding:0 5px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-flex-wrap:wrap;-ms-flex-wrap:wrap;flex-wrap:wrap;-webkit-box-pack:justify;-webkit-justify-content:space-between;-ms-flex-pack:justify;justify-content:space-between;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;line-height:50px;background-color:#FFFFFF;border-bottom:1px solid #E3E7E8;margin-bottom:65px;}
.filter.jsx-1514242801{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;height:48px;}
.action.jsx-1514242801{-webkit-flex:0 0 auto;-ms-flex:0 0 auto;flex:0 0 auto;line-height:normal;}
.title.jsx-1514242801{height:65px;line-height:65px;-webkit-flex:0 0 100%;-ms-flex:0 0 100%;flex:0 0 100%;-webkit-order:1;-ms-flex-order:1;order:1;text-align:center;}
h1.jsx-1514242801{margin:0 0;}
.Page.content .TitleBar{display:none;}
@media (min-width:800px){.TitleBar.jsx-1514242801{height:50px;padding:0 25px;display:-webkit-box !important;display:-webkit-flex !important;display:-ms-flexbox !important;display:flex !important;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-flex-wrap:nowrap;-ms-flex-wrap:nowrap;flex-wrap:nowrap;-webkit-box-pack:justify;-webkit-justify-content:space-between;-ms-flex-pack:justify;justify-content:space-between;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;margin-bottom:29px;margin-top:50px;background-color:#FFFFFF;border-bottom:1px solid #E3E7E8;}.filter.jsx-1514242801{-webkit-flex:0 0 33%;-ms-flex:0 0 33%;flex:0 0 33%;line-height:normal;}.action.jsx-1514242801{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-box-pack:end;-webkit-justify-content:flex-end;-ms-flex-pack:end;justify-content:flex-end;line-height:normal;-webkit-flex:0 0 33%;-ms-flex:0 0 33%;flex:0 0 33%;}.action.jsx-1514242801 a{line-height:0;}.title.jsx-1514242801{-webkit-order:0;-ms-flex-order:0;order:0;-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;text-align:center;}h1.jsx-1514242801{margin:0 0;}}</style><style id="__jsx-3293774837">.CommentCounter.jsx-3293774837{width:54px;height:54px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:column;-ms-flex-direction:column;flex-direction:column;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;border-radius:4px;border:1px solid #E6EAEB;background-color:#F0F4F5;cursor:pointer;}
.CommentCounter.jsx-3293774837 .icon.jsx-3293774837{font-size:13px;line-height:0;color:#33AACC;}
.CommentCounter.jsx-3293774837 .icon.jsx-3293774837 svg{width:16px;height:16px;fill:#33AACC;}
.CommentCounter.jsx-3293774837 .count.jsx-3293774837{font-size:13px;font-weight:bold;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;color:#686F75;}
.CommentCounter.jsx-3293774837:hover{background-color:#FFFFFF;}</style><style id="__jsx-1972554161">.Upvote.jsx-1972554161{position:relative;width:54px;height:54px;overflow:hidden;border-radius:4px;border:1px solid #E6EAEB;background-color:#F0F4F5;cursor:pointer;}
.Upvote.news.jsx-1972554161{width:45px;height:35px;border:none;background-color:transparent;}
.Upvote.comment.jsx-1972554161{width:45px;height:25px;border:none;background-color:transparent;}
.Upvote.jsx-1972554161>div.jsx-1972554161{position:absolute;top:0;-webkit-transition:all 0.15s ease-in-out;transition:all 0.15s ease-in-out;}
.Upvote.upvoted.jsx-1972554161>div.jsx-1972554161{top:-54px;}
.Upvote.upvoted.news.jsx-1972554161>div.jsx-1972554161{top:-35px;}
.Upvote.upvoted.comment.jsx-1972554161>div.jsx-1972554161{top:-25px;}
.Upvote.jsx-1972554161>div.jsx-1972554161>div.jsx-1972554161{display:-webkit-inline-box;display:-webkit-inline-flex;display:-ms-inline-flexbox;display:inline-flex;-webkit-flex-direction:column;-ms-flex-direction:column;flex-direction:column;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;width:54px;height:54px;}
.Upvote.news.jsx-1972554161>div.jsx-1972554161>div.jsx-1972554161{width:45px;height:35px;}
.Upvote.comment.jsx-1972554161>div.jsx-1972554161>div.jsx-1972554161{width:45px;height:25px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;}
.Upvote.jsx-1972554161 .icon.jsx-1972554161{font-size:13px;line-height:0;color:#33AACC;}
.Upvote.comment.jsx-1972554161 .icon.jsx-1972554161{padding-right:5px;}
.Upvote.comment.jsx-1972554161 .count.jsx-1972554161{padding-bottom:1px;}
.Upvote.jsx-1972554161 .icon.jsx-1972554161 svg{width:12px;height:12px;fill:#33AACC;}
.Upvote.jsx-1972554161 .count.jsx-1972554161{font-size:13px;font-weight:bold;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;color:#686F75;}
.Upvote.jsx-1972554161:hover{background-color:#FFFFFF;}
.Upvote.news.jsx-1972554161:hover,.Upvote.comment.jsx-1972554161:hover{background-color:#EBF4F7;}
.Upvote.news.jsx-1972554161:hover .count.jsx-1972554161,.Upvote.comment.jsx-1972554161:hover .count.jsx-1972554161{color:#33AACC;}
.Upvote.jsx-1972554161 .voted.jsx-1972554161{background-color:#33AACC;border-color:#33AACC;}
.Upvote.news.jsx-1972554161 .voted.jsx-1972554161,.Upvote.comment.jsx-1972554161 .voted.jsx-1972554161{background-color:#FFFFFF;border:none;}
.Upvote.jsx-1972554161 .voted.jsx-1972554161 .icon.jsx-1972554161 svg{fill:#195B73;}
.Upvote.news.jsx-1972554161 .voted.jsx-1972554161 .icon.jsx-1972554161 svg,.Upvote.comment.jsx-1972554161 .voted.jsx-1972554161 .icon.jsx-1972554161 svg{fill:#36D57D;}
.Upvote.jsx-1972554161 .voted.jsx-1972554161 .count.jsx-1972554161{color:#FFFFFF;}
.Upvote.news.jsx-1972554161 .voted.jsx-1972554161 .count.jsx-1972554161,.Upvote.comment.jsx-1972554161 .voted.jsx-1972554161 .count.jsx-1972554161{color:#36D57D;}
@media (min-width:800px){.Upvote.news.jsx-1972554161{height:45px;}.Upvote.comment.jsx-1972554161{height:25px;}.Upvote.upvoted.news.jsx-1972554161>div.jsx-1972554161{top:-45px;}.Upvote.upvoted.comment.jsx-1972554161>div.jsx-1972554161{top:-25px;}.Upvote.news.jsx-1972554161>div.jsx-1972554161>div.jsx-1972554161{height:45px;}.Upvote.comment.jsx-1972554161>div.jsx-1972554161>div.jsx-1972554161{height:25px;}}</style><style id="__jsx-494086174">.Social.jsx-494086174{-webkit-flex:0 0 auto;-ms-flex:0 0 auto;flex:0 0 auto;}
.icons.jsx-494086174{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;}
.icon.jsx-494086174{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;width:28px;height:28px;border:1px solid #E3E7E8;background-color:#FFFFFF;border-radius:50%;}
.icon.jsx-494086174:hover{background-color:#F0F4F5;}
.centerIcon.jsx-494086174{margin:0 10px;}
.icon.jsx-494086174 svg{fill:#686F75;-webkit-align-self:center;-ms-flex-item-align:center;align-self:center;-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;}
@media (min-width:800px){.Social.jsx-494086174{margin-top:18px;}.vertical.jsx-494086174{margin-top:10px;}.vertical.jsx-494086174 .icons.jsx-494086174{-webkit-flex-direction:column;-ms-flex-direction:column;flex-direction:column;}.vertical.jsx-494086174 .centerIcon.jsx-494086174{margin:10px 0;}}</style><style id="__jsx-3208234818">.Avatar.jsx-3208234818{display:inline-block;background-size:cover;background-color:#E6EAEB;background-repeat:no-repeat;}</style><style id="__jsx-566588255">.Author.jsx-566588255 a.jsx-566588255{display:-webkit-inline-box;display:-webkit-inline-flex;display:-ms-inline-flexbox;display:inline-flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;cursor:pointer;}
.info.jsx-566588255{margin-left:9px;white-space:nowrap;}
.mirrored.jsx-566588255 .info.jsx-566588255{margin:0 9px 0 0;-webkit-order:-1;-ms-flex-order:-1;order:-1;}
.name.jsx-566588255{font-size:13px;font-weight:bold;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;color:#3D4251;text-decoration:none;}
.name.jsx-566588255:hover{color:#33AACC;}
.date.jsx-566588255{font-size:11px;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;color:#686F75;}</style><style id="__jsx-1764811326">.Tag.jsx-1764811326{display:inline-block;border-radius:4px;background-color:#F0F4F5;border:solid 1px #E6EAEB;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;color:#686F75;cursor:default;}
.title.jsx-1764811326{line-height:20px;padding:0 8px;font-size:11px;text-transform:uppercase;}
.Tag.mustRead.jsx-1764811326{background-color:#AD86CE;border-color:#AD86CE;color:#FFFFFF;font-weight:bold;}
.Tag.jsx-1764811326:hover{background-color:#FFFFFF;}
.Tag.mustRead.jsx-1764811326:hover{background-color:#CEABEC;border-color:#CEABEC;}</style><style id="__jsx-1022557955">.more.jsx-1022557955{font-size:11px;cursor:default;color:#686F75;}
.more.jsx-1022557955:hover{text-decoration:underline;}</style><style id="__jsx-422934526">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</style><style id="__jsx-2792531181">.TagLine.jsx-2792531181{display:inline-block;white-space:nowrap;}
.TagLine.jsx-2792531181>.Tag{margin-right:10px;}
.more.jsx-2792531181{font-size:11px;}</style><style id="__jsx-1091791248">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</style><style id="__jsx-3956319705">.PostAComment.jsx-3956319705{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;padding:0 0 60px;}</style><style id="__jsx-2506565400">.SidebarSocial.jsx-2506565400{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;font-size:11px;font-weight:bold;}
.rss.jsx-2506565400{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;line-height:50px;}
.rss.jsx-2506565400 svg{padding-right:7px;fill:#FFC844;}
.rss.jsx-2506565400 a.jsx-2506565400{text-decoration:none;color:#FFFFFF;}
.rss.jsx-2506565400 a.jsx-2506565400:hover{text-decoration:none;color:#FFC844;}
.icons.jsx-2506565400{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;}
.icon.jsx-2506565400{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;margin:0 7px;width:30px;height:30px;background-color:#195B73;border-radius:50%;}
.icon.jsx-2506565400 svg{fill:#7ECCE2;-webkit-align-self:center;-ms-flex-item-align:center;align-self:center;-webkit-flex:1 1 0;-ms-flex:1 1 0;flex:1 1 0;}
.icon.jsx-2506565400:hover svg{fill:#FFFFFF;}
.menu.jsx-2506565400{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;line-height:44px;}
.menuItem.jsx-2506565400{-webkit-flex:0 0 auto;-ms-flex:0 0 auto;flex:0 0 auto;padding:5px;text-decoration:none;color:#195B73;}
.menuItem--active.jsx-2506565400,a.jsx-2506565400:hover{color:#F0F4F5;}
@media (min-width:800px) and (min-height:585px){.SidebarSocial.jsx-2506565400{width:220px;position:fixed;bottom:0;left:0;}}</style><style id="__jsx-879378290">.BottomBar.jsx-879378290{position:fixed;bottom:0;width:100vw;padding:15px;z-index:300;background-color:#FFFFFF;box-shadow:0 -2px 26px 0 rgba(168,168,168,0.5);}
.BottomBar.editor.jsx-879378290{padding-top:5px;}
.barView.jsx-879378290{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:start;-webkit-justify-content:flex-start;-ms-flex-pack:start;justify-content:flex-start;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;}
.editor.jsx-879378290 .barView.jsx-879378290{display:none;}
.blueBar.jsx-879378290{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;height:50px;margin-left:15px;padding:0 15px;color:#33AACC;line-height:50px;border-radius:4px;background-color:#ebf4f7;}
.editorView.jsx-879378290{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;}
.editorView.jsx-879378290 .avatar{display:none;}
.bar.jsx-879378290 .editorView.jsx-879378290{display:none;}
.hideBar.jsx-879378290{display:none;}
@media (min-width:800px){.BottomBar.jsx-879378290{width:calc(100% - 220px);margin-left:220px;}.editorView.jsx-879378290 .avatar{display:block;}}</style><style id="__jsx-1028385822">.Layout.jsx-1028385822{-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:column;-ms-flex-direction:column;flex-direction:column;-webkit-box-pack:start;-webkit-justify-content:flex-start;-ms-flex-pack:start;justify-content:flex-start;-webkit-align-items:stretch;-webkit-box-align:stretch;-ms-flex-align:stretch;align-items:stretch;}
.Layout--openMenu.jsx-1028385822{min-height:100vh;}
.Main.jsx-1028385822{min-height:100vh;-webkit-flex:1 1 auto;-ms-flex:1 1 auto;flex:1 1 auto;background-color:#F0F4F5;}
.Layout--banner.jsx-1028385822 .Main.jsx-1028385822{margin-top:55px;min-height:calc(100vh - 55px);}
.Layout.bar.jsx-1028385822:not(.Layout--openMenu) .SidebarSocial{margin-bottom:90px;}
.Layout.editor.jsx-1028385822:not(.Layout--openMenu) .SidebarSocial{margin-bottom:300px;}
@media (min-width:800px){.Main.jsx-1028385822{margin-left:220px;}.Layout--banner.jsx-1028385822 .Main.jsx-1028385822{margin-top:80px;min-height:calc(100vh - 80px);}.Layout.bar.jsx-1028385822:not(.Layout--openMenu) .SidebarSocial,.Layout.editor.jsx-1028385822:not(.Layout--openMenu) .SidebarSocial{margin-bottom:0;}.Layout.bar.jsx-1028385822 .Main > div:last-child{margin-bottom:90px;}.Layout.editor.jsx-1028385822 .Main > div:last-child{margin-bottom:300px;}}</style><style id="__jsx-1464850800">.Tutorial.jsx-1464850800{margin:0 0px 30px;padding:20px 0 0;background-color:#FFFFFF;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:column;-ms-flex-direction:column;flex-direction:column;}
.preface.jsx-1464850800{margin:0 20px;}
.author.jsx-1464850800{margin-bottom:10px;}
h1.jsx-1464850800{margin-top:20px;}
.illustration.jsx-1464850800{margin-bottom:30px;}
.illustration.jsx-1464850800 img.jsx-1464850800{max-width:100%;}
.Tutorial.jsx-1464850800 .social__top .voteAndSocial,.social__bottom.jsx-1464850800 .voteAndSocial.jsx-1464850800{padding:40px 20px 20px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:justify;-webkit-justify-content:space-between;-ms-flex-pack:justify;justify-content:space-between;-webkit-align-items:flex-end;-webkit-box-align:flex-end;-ms-flex-align:flex-end;align-items:flex-end;}
.Tutorial.jsx-1464850800 .voteAndSocial.jsx-1464850800>div.jsx-1464850800{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-direction:row;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:start;-webkit-justify-content:flex-start;-ms-flex-pack:start;justify-content:flex-start;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;}
.Tutorial.jsx-1464850800 .voteAndSocial.jsx-1464850800>div.jsx-1464850800 .CommentCounter{margin-left:10px;}
@media (min-width:800px){.Tutorial.jsx-1464850800{margin:0 auto 30px;padding:30px 100px 100px;max-width:1120px;border-radius:4px;border:1px solid #E3E7E8;}.preface.jsx-1464850800{margin:0;}.Tutorial.jsx-1464850800 .social__top{position:absolute;margin-top:220px;}.Tutorial.jsx-1464850800 .social__top .voteAndSocial{position:absolute;left:-100px;top:0;width:100px;height:auto;-webkit-flex-direction:column;-ms-flex-direction:column;flex-direction:column;-webkit-box-pack:start;-webkit-justify-content:flex-start;-ms-flex-pack:start;justify-content:flex-start;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;}.Tutorial.jsx-1464850800 .voteAndSocial.jsx-1464850800>div.jsx-1464850800{-webkit-flex-direction:column;-ms-flex-direction:column;flex-direction:column;}.Tutorial.jsx-1464850800 .voteAndSocial > div .CommentCounter{margin-left:0;margin-bottom:10px;}}</style><style id="__jsx-2612661084">*{box-sizing:border-box;}
html,body{min-height:100vh;margin:0;padding:0;background-image: linear-gradient(207deg, #2388B0, #33AACC); background-size: 100vw 100vh; background-attachment: fixed; background-repeat: no-repeat;}
body.ReactModal__Body--open{overflow:hidden;}
.ReactModal__Content{width:100%;}
img{margin:auto;}
.mobileOnlyShow{display:block !important;}
.mobileOnlyHide{display:none !important;}
.mobileOnly{display:block !important;}
.desktopOnly{display:none !important;}
@media (min-width:800px){body{background-image: linear-gradient(207deg, #2388B0, #33AACC); background-size: 220px 100vh; background-attachment: fixed; background-repeat: no-repeat;}.ReactModal__Content{width:auto;}.mobileOnlyShow{display:block !important;}.mobileOnlyHide{display:block !important;}.mobileOnly{display:none !important;}.desktopOnly{display:block !important;}}</style><style id="__jsx-63629563">body,input,button,select,textarea{font-family:'Lato',sans-serif;color:#686F75;font-size:15px;}
h1,.h1,h2,h3,h4,h5{font-family:'Lato',sans-serif;}
.pageTitle{font-family:'Lato',sans-serif;font-size:32px;font-weight:bold;line-height:1.3em;margin-bottom:0.5em;}
.pageDescription{font-family:'Lora',serif;font-size:20.8px;line-height:1.5em;margin-bottom:1.4em;color:#3D4251;}
h1,.h1{font-size:29px;color:#3D4251;font-weight:bold;}
h2{font-size:20px;-webkit-letter-spacing:0.3px;-moz-letter-spacing:0.3px;-ms-letter-spacing:0.3px;letter-spacing:0.3px;line-height:1.33;font-weight:bold;margin:18px 0px;color:#3D4251;}
h2.blue{color:#33AACC;}
a{color:#33AACC;text-decoration:none;}
.blocText{font-size:15px;-webkit-letter-spacing:0.2px;-moz-letter-spacing:0.2px;-ms-letter-spacing:0.2px;letter-spacing:0.2px;line-height:1.47;color:#686F75;}
label{display:block;width:100%;margin-bottom:8px;font-size:13px;}
label span{float:right;font-weight:300;}
input,textarea{padding:15px;font-weight:300;color:#3D4251;background-color:#F0F4F5;border:1px solid transparent;border-radius:4px;outline-style:none;}
input:disabled,textarea:disabled{color:#686F75;background-color:#E6EAEB;}
input.error,textarea.error{border:1px solid #FE5C5C;}
input:focus,textarea:focus{border:1px solid #33AACC;-webkit-transition:border 150ms ease-out;transition:border 150ms ease-out;}
input::-webkit-input-placeholder,textarea::-webkit-input-placeholder{color:#33AACC;-webkit-transition:color 150ms ease-out;transition:color 150ms ease-out;}
input::-moz-placeholder,textarea::-moz-placeholder{color:#33AACC;-webkit-transition:color 150ms ease-out;transition:color 150ms ease-out;}
input:-ms-input-placeholder,textarea:-ms-input-placeholder{color:#33AACC;-webkit-transition:color 150ms ease-out;transition:color 150ms ease-out;}
input::placeholder,textarea::placeholder{color:#33AACC;-webkit-transition:color 150ms ease-out;transition:color 150ms ease-out;}
input:focus::-webkit-input-placeholder,textarea:focus::-webkit-input-placeholder{color:transparent;}
input:focus::-moz-placeholder,textarea:focus::-moz-placeholder{color:transparent;}
input:focus:-ms-input-placeholder,textarea:focus:-ms-input-placeholder{color:transparent;}
input:focus::placeholder,textarea:focus::placeholder{color:transparent;}
input.small,textarea.small{margin-bottom:19px;padding:8px 10px;font-size:13px;}
textarea.small{min-height:55px;}
@media (min-width:800px){h1,.h1{font-size:36px;}h2{font-size:32px;}.pageTitle{font-size:40px;}.pageDescription{font-size:26px;}}</style></head><body><div id="__next"><div data-reactroot=""><div class="Page content"><div class="jsx-1028385822 Layout bar"><div class="jsx-499055511 SidebarMenu"><div class="jsx-396080995 Logo"><a href="https://www.datacamp.com" class="jsx-396080995 Logo__image"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1367.47 306.77"><path d="M201.49 130.16c2.64-10.87 2.31-21.09-3.62-35.38 0 0 9.55 3.71 8.56-3.65S194.91 76 187 71.11c-3.48-2.17-12.89-6.79-25.52-9.6l2.36-5.32-.66-.32c-19.59-9.54-42.24-.89-42.47-.8l-.7.27 2.24 5.92a78 78 0 0 0-19 7.09C50 96.68 77 152 93.5 165.17s8.89 40 0 64.31H165c1-4.55.13 2.24 3.46-15.91s16.18-11.41 26.3-12 8.52-7.66 8.4-15.56c4.94-2.22 4.94-4.57 1.64-7.41 4.28-4 3.62-4 1.32-7.83s-.66-5.68-.66-5.68 6.92-1.35 7.9-5c.32-7.89-14.5-19.09-11.87-29.93zm-14.78-2.28l-10.59-3.6c-.56 1.45-6 14.9-13 17.27l-6.68-8.84c-3.21 2.51-10.54 4.72-14.07 3.69v-.32h-.19l.2 24.36c-14.05 1.45-30.84-7.06-38.88-18.77l-8.78 6.67c-10-12.07-11.51-26.62-11.62-35h11.77c0-9.27 3.62-21.34 8.72-28l9.23 6.52c.75-.93 7.72-9.27 17.05-12.28h.14l-6.67-17.64c14.09-4.06 24.44-4 35.7.19a3.87 3.87 0 0 1 1 .48l.18.13-1.99 5.26c.53.23 8 3.59 11.09 6.74l2.49-3.44a42.47 42.47 0 0 1 19 25.34L187 98v-.1a55.32 55.32 0 0 1-.28 29.98z"></path><path d="M141.69 95.69a11.77 11.77 0 1 0 11.76 11.77 11.78 11.78 0 0 0-11.76-11.77zM486.07 147.93a85.48 85.48 0 0 1-5.79 31.92 71.67 71.67 0 0 1-41.54 41.32 89 89 0 0 1-32.79 5.83h-60.24V68.9h60.23a88.33 88.33 0 0 1 32.79 5.85A74 74 0 0 1 464 91a72.76 72.76 0 0 1 16.29 25 85.49 85.49 0 0 1 5.78 31.93zm-30.17 0a73.61 73.61 0 0 0-3.44-23.34 48.4 48.4 0 0 0-9.95-17.49 43.45 43.45 0 0 0-15.74-11 54 54 0 0 0-20.82-3.83h-30.72v111.3h30.72a54 54 0 0 0 20.82-3.83 43.39 43.39 0 0 0 15.74-11 48.37 48.37 0 0 0 9.95-17.49 73.6 73.6 0 0 0 3.44-23.32zM505.36 130.44q19.35-17.71 46.57-17.71a45.54 45.54 0 0 1 17.6 3.22 37.21 37.21 0 0 1 13.12 9 38.4 38.4 0 0 1 8.14 13.72 52.72 52.72 0 0 1 2.79 17.49V227h-12.25a12.38 12.38 0 0 1-5.9-1.15q-2.08-1.15-3.28-4.65l-2.4-8.09a97.29 97.29 0 0 1-8.31 6.72 48.91 48.91 0 0 1-8.42 4.86 45.32 45.32 0 0 1-9.35 3 53.93 53.93 0 0 1-11 1 43.08 43.08 0 0 1-13.12-1.91 28.78 28.78 0 0 1-10.38-5.74 25.73 25.73 0 0 1-6.78-9.51 33.72 33.72 0 0 1-2.4-13.23 26.32 26.32 0 0 1 1.42-8.47 24.76 24.76 0 0 1 4.65-8 38.63 38.63 0 0 1 8.36-7.21 54.43 54.43 0 0 1 12.63-5.9 109.08 109.08 0 0 1 17.44-4.1 174.35 174.35 0 0 1 22.74-1.91v-6.56q0-11.26-4.81-16.67t-13.88-5.41a33 33 0 0 0-10.88 1.53 44.91 44.91 0 0 0-7.6 3.44q-3.28 1.91-6 3.44a11.78 11.78 0 0 1-6 1.53 7.79 7.79 0 0 1-4.81-1.48 12.33 12.33 0 0 1-3.17-3.44zm61.87 48.64a149.08 149.08 0 0 0-19.68 2 52.42 52.42 0 0 0-12.79 3.77 16.8 16.8 0 0 0-6.89 5.36 11.63 11.63 0 0 0-2.08 6.67q0 7.11 4.21 10.17t11 3.06a32 32 0 0 0 14.37-3 42.69 42.69 0 0 0 11.86-9.11zM657.79 228.72q-14.65 0-22.46-8.25t-7.82-22.79V135H616a5.26 5.26 0 0 1-3.72-1.42 5.53 5.53 0 0 1-1.53-4.26v-10.68l18-3 5.68-30.61a6 6 0 0 1 2.08-3.39 6.18 6.18 0 0 1 3.94-1.2h14v35.36h30V135h-30v60.78q0 5.25 2.57 8.2a8.85 8.85 0 0 0 7 3 12.7 12.7 0 0 0 4.21-.6 23 23 0 0 0 3-1.26q1.26-.66 2.24-1.26a3.75 3.75 0 0 1 2-.6 3.1 3.1 0 0 1 2 .6 9.23 9.23 0 0 1 1.64 1.8l8.09 13.12a40.87 40.87 0 0 1-13.55 7.43 50.47 50.47 0 0 1-15.86 2.51zM702.11 130.44q19.35-17.71 46.57-17.71a45.54 45.54 0 0 1 17.6 3.22 37.19 37.19 0 0 1 13.12 9 38.37 38.37 0 0 1 8.14 13.72 52.72 52.72 0 0 1 2.79 17.49V227h-12.25a12.37 12.37 0 0 1-5.9-1.15q-2.08-1.15-3.28-4.65l-2.4-8.09a97.21 97.21 0 0 1-8.31 6.72 49 49 0 0 1-8.42 4.86 45.33 45.33 0 0 1-9.35 3 53.92 53.92 0 0 1-11 1 43.08 43.08 0 0 1-13.12-1.91 28.78 28.78 0 0 1-10.38-5.74 25.74 25.74 0 0 1-6.78-9.51 33.72 33.72 0 0 1-2.4-13.23 26.31 26.31 0 0 1 1.42-8.47 24.76 24.76 0 0 1 4.65-8 38.66 38.66 0 0 1 8.36-7.21 54.45 54.45 0 0 1 12.63-5.9 109.07 109.07 0 0 1 17.44-4.1 174.32 174.32 0 0 1 22.76-1.93v-6.56q0-11.26-4.81-16.67t-13.88-5.41a33 33 0 0 0-10.88 1.53 44.89 44.89 0 0 0-7.6 3.44q-3.28 1.91-6 3.44a11.79 11.79 0 0 1-6 1.53 7.79 7.79 0 0 1-4.81-1.48 12.33 12.33 0 0 1-3.17-3.44zM764 179.09a149.06 149.06 0 0 0-19.68 2 52.43 52.43 0 0 0-12.79 3.77 16.81 16.81 0 0 0-6.89 5.36 11.63 11.63 0 0 0-2.08 6.67q0 7.11 4.21 10.17t11 3.06a32 32 0 0 0 14.37-3A42.68 42.68 0 0 0 764 198zM929.42 189.69a5.87 5.87 0 0 1 4.26 1.86l11.59 12.57a63.64 63.64 0 0 1-23.67 18.26q-14 6.34-33.72 6.34-17.6 0-31.65-6a69.71 69.71 0 0 1-24-16.73A73.19 73.19 0 0 1 817 180.4a96 96 0 0 1-5.3-32.47 90.36 90.36 0 0 1 5.68-32.63 75 75 0 0 1 16-25.52A72.5 72.5 0 0 1 858 73.11a81.77 81.77 0 0 1 31.7-6q17.27 0 30.66 5.68a73.08 73.08 0 0 1 22.83 14.91l-9.84 13.66a9 9 0 0 1-2.24 2.29 6.35 6.35 0 0 1-3.77 1 7.2 7.2 0 0 1-3.39-.93q-1.75-.93-3.83-2.29t-4.81-3a39.67 39.67 0 0 0-6.34-3 51.92 51.92 0 0 0-8.36-2.29 57.87 57.87 0 0 0-11-.93A48.74 48.74 0 0 0 870.23 96a42.16 42.16 0 0 0-15.14 10.93 50.38 50.38 0 0 0-9.84 17.49 73.27 73.27 0 0 0-3.5 23.56 69.25 69.25 0 0 0 3.77 23.72 52.12 52.12 0 0 0 10.22 17.49 43.61 43.61 0 0 0 15.2 10.81 47 47 0 0 0 18.8 3.77 81.89 81.89 0 0 0 10.88-.66 46.17 46.17 0 0 0 9-2.08 39.7 39.7 0 0 0 7.76-3.66 48.48 48.48 0 0 0 7.27-5.52 10.31 10.31 0 0 1 2.29-1.58 5.56 5.56 0 0 1 2.48-.58zM961.6 130.44q19.35-17.71 46.57-17.71a45.54 45.54 0 0 1 17.6 3.22 37.19 37.19 0 0 1 13.12 9 38.37 38.37 0 0 1 8.14 13.72 52.72 52.72 0 0 1 2.79 17.49V227h-12.24a12.37 12.37 0 0 1-5.9-1.15q-2.08-1.15-3.28-4.65l-2.4-8.09a97.21 97.21 0 0 1-8.31 6.72 49 49 0 0 1-8.42 4.86 45.33 45.33 0 0 1-9.35 3 53.92 53.92 0 0 1-11 1 43.08 43.08 0 0 1-13.12-1.91 28.78 28.78 0 0 1-10.38-5.74 25.74 25.74 0 0 1-6.78-9.51 33.73 33.73 0 0 1-2.4-13.23 26.31 26.31 0 0 1 1.42-8.47 24.76 24.76 0 0 1 4.65-8 38.66 38.66 0 0 1 8.36-7.21 54.45 54.45 0 0 1 12.63-5.9 109.07 109.07 0 0 1 17.44-4.1 174.32 174.32 0 0 1 22.74-1.91v-6.56q0-11.26-4.81-16.67t-13.88-5.41a33 33 0 0 0-10.88 1.53 44.89 44.89 0 0 0-7.6 3.44q-3.28 1.91-6 3.44a11.79 11.79 0 0 1-6 1.53 7.79 7.79 0 0 1-4.81-1.48 12.33 12.33 0 0 1-3.17-3.44zm61.87 48.64a149.06 149.06 0 0 0-19.68 2 52.43 52.43 0 0 0-12.79 3.8 16.81 16.81 0 0 0-6.89 5.36 11.63 11.63 0 0 0-2.08 6.67q0 7.11 4.21 10.17t11 3.06a32 32 0 0 0 14.37-3 42.68 42.68 0 0 0 11.86-9.13zM1078.18 227V114.81h16.51a6.63 6.63 0 0 1 6.89 4.92l1.75 8.31a63.82 63.82 0 0 1 6.18-6 39.66 39.66 0 0 1 6.89-4.7 37.29 37.29 0 0 1 7.87-3.12 35.05 35.05 0 0 1 9.24-1.15q10.6 0 17.43 5.74a34.56 34.56 0 0 1 10.22 15.25 34.23 34.23 0 0 1 6.56-9.57 35.9 35.9 0 0 1 8.63-6.5 39.77 39.77 0 0 1 10-3.72 48.07 48.07 0 0 1 10.66-1.2 44.82 44.82 0 0 1 16.51 2.84 31.69 31.69 0 0 1 12.13 8.31 36.63 36.63 0 0 1 7.49 13.34 58.1 58.1 0 0 1 2.57 18V227h-27v-71.41q0-10.71-4.7-16.12t-13.77-5.41a20.57 20.57 0 0 0-7.71 1.42 18.37 18.37 0 0 0-6.23 4.1 18.73 18.73 0 0 0-4.21 6.72 26.13 26.13 0 0 0-1.53 9.29V227h-27.11v-71.41q0-11.26-4.54-16.4t-13.28-5.14a21.83 21.83 0 0 0-11 2.9 36.66 36.66 0 0 0-9.46 7.92V227zM1289.85 130.12a58.51 58.51 0 0 1 15.63-12.57q8.74-4.81 20.55-4.81a36.79 36.79 0 0 1 16.78 3.83 37.68 37.68 0 0 1 13.12 11.09 53.26 53.26 0 0 1 8.53 17.93 90.21 90.21 0 0 1 3 24.43 76.84 76.84 0 0 1-3.39 23.28 57 57 0 0 1-9.67 18.58 44.72 44.72 0 0 1-15.19 12.3 44.22 44.22 0 0 1-19.95 4.43 40.23 40.23 0 0 1-16.07-2.9 39.23 39.23 0 0 1-11.92-8v45.91h-27V114.81h16.51a6.63 6.63 0 0 1 6.89 4.92zm1.42 67.77a26.57 26.57 0 0 0 10 7.87 29.76 29.76 0 0 0 11.75 2.3 25.79 25.79 0 0 0 11-2.3 21.63 21.63 0 0 0 8.36-7 34.62 34.62 0 0 0 5.3-11.86 67.79 67.79 0 0 0 1.86-16.89 75 75 0 0 0-1.58-16.67 32.22 32.22 0 0 0-4.54-11.09 17.92 17.92 0 0 0-7.16-6.23 22.34 22.34 0 0 0-9.57-2 27.28 27.28 0 0 0-14.32 3.55 43.46 43.46 0 0 0-11.15 10z"></path><path d="M144.06 306.77a9.83 9.83 0 0 1-4.72-1.21L23.79 242a9.82 9.82 0 0 1-5-7.56L.06 57.52a9.77 9.77 0 0 1 6.5-10.29L139.37.55a9.88 9.88 0 0 1 6.43 0L281.5 47.2a9.86 9.86 0 0 1 6.5 10.47L266.47 234.6a9.85 9.85 0 0 1-4.91 7.35l-112.68 63.56a9.84 9.84 0 0 1-4.82 1.26zm-110-77l110 60.49 107.22-60.48L271.89 60.5 142.64 16 16.15 60.5z"></path></svg></a></div><div class="jsx-499055511 icon mobileOnly"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 80 70"><path d="M6 1a6 6 0 1 0 0 12h68a6 6 0 0 0 0-12H6zm0 28a6 6 0 1 0 0 12h68a6 6 0 0 0 0-12H6zm0 28a6 6 0 1 0 0 12h68a6 6 0 0 0 0-12H6z"></path></svg></div></div><div class="jsx-2769082546 Menu mobileOnlyHide"><div class="jsx-2769082546 section"><h5 class="jsx-2769082546">community</h5><nav class="jsx-2769082546"><div><a target="_self" class="jsx-2769082546 item" href="/community"><div class="jsx-2769082546 image"><svg height="14" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 23 23"><path id="a" d="M2 4.5h20a1.5 1.5 0 0 1 0 3H2a1.5 1.5 0 0 1 0-3zm0 6h14a1.5 1.5 0 0 1 0 3H2a1.5 1.5 0 0 1 0-3zm0 6h20a1.5 1.5 0 0 1 0 3H2a1.5 1.5 0 0 1 0-3z"></path></svg></div><div class="jsx-2769082546 text">News</div><div class="jsx-2769082546 statusIcon"><svg height="20" xmlns="http://www.w3.org/2000/svg" width="40" viewBox="0 0 40 20"><g fill="none" fill-rule="evenodd"><rect width="40" height="20" fill="#FFC844" rx="4"></rect><text fill="#3D4251" font-family="Lato-Bold, Lato" font-size="11" font-weight="bold" letter-spacing=".5"><tspan x="5" y="14">BETA</tspan></text></g></svg></div></a></div><div><a target="_self" class="jsx-2769082546 item" href="https://www.datacamp.com/resources"><div class="jsx-2769082546 image"><svg height="14" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 21.75 29.76"><path d="M15.56 22.57a1.5 1.5 0 0 1-1.5-1.5 7.66 7.66 0 0 1 2.47-5.29 7.38 7.38 0 0 0 2.21-5.31A7.48 7.48 0 0 0 11.28 3h-.82a7.47 7.47 0 0 0-5.2 12.83 7.63 7.63 0 0 1 2.42 5.23 1.5 1.5 0 0 1-3 0 4.65 4.65 0 0 0-1.45-3A10.47 10.47 0 0 1 10.47 0h.82a10.47 10.47 0 0 1 7.28 18 4.68 4.68 0 0 0-1.5 3.08 1.5 1.5 0 0 1-1.51 1.49zM16.5 24.26a5.5 5.5 0 0 1-11 0"></path><path d="M10.89 22.56a1.5 1.5 0 0 1-1.5-1.5v-8.84a1.5 1.5 0 0 1 3 0v8.84a1.5 1.5 0 0 1-1.5 1.5z"></path></svg></div><div class="jsx-2769082546 text">Resource Center</div></a></div><div><a target="_self" class="jsx-2769082546 item active" href="/community/tutorials"><div class="jsx-2769082546 image"><svg height="14" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 24.22"><path d="M16.23 24.22a2 2 0 0 1-.73-.14L7 20.79a2 2 0 0 1-1.29-1.88v-4a1.5 1.5 0 0 1 3 0v3.36l7.54 2.92 7.54-2.92v-3.45a1.5 1.5 0 0 1 3 0v4.09a2 2 0 0 1-1.29 1.88L17 24.08a2 2 0 0 1-.77.14zm-.35-2.94zm.7 0z"></path><path d="M16.23 13.35a2 2 0 0 1-.62-.1C9.17 11.16 2.36 9 1.61 8.76a2 2 0 0 1-.25-3.87l14-4.78a2 2 0 0 1 1.3 0l14 4.78a2 2 0 0 1 0 3.81l-13.8 4.55a2 2 0 0 1-.63.1zm-.31-3zM5.21 6.74c3.49 1.11 9.07 2.92 11 3.56l10.68-3.53L16 3.05z"></path></svg></div><div class="jsx-2769082546 text">Tutorials</div></a></div><div><a target="_self" class="jsx-2769082546 item" href="/community/data-science-cheatsheets"><div class="jsx-2769082546 image"><svg height="14" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 26"><path d="M18.5 26h-13A5.51 5.51 0 0 1 0 20.5v-15A5.51 5.51 0 0 1 5.5 0h13A5.51 5.51 0 0 1 24 5.5v15a5.51 5.51 0 0 1-5.5 5.5zM5.5 3A2.5 2.5 0 0 0 3 5.5v15A2.5 2.5 0 0 0 5.5 23h13a2.5 2.5 0 0 0 2.5-2.5v-15A2.5 2.5 0 0 0 18.5 3z"></path><path d="M16 11H8a1.5 1.5 0 0 1 0-3h8a1.5 1.5 0 0 1 0 3zM16 18H8a1.5 1.5 0 0 1 0-3h8a1.5 1.5 0 0 1 0 3z"></path></svg></div><div class="jsx-2769082546 text">Cheat Sheets</div></a></div><div><a target="_self" class="jsx-2769082546 item" href="/community/open-courses"><div class="jsx-2769082546 image"><svg height="14" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 34 26"><path d="M28.5 26h-23A5.51 5.51 0 0 1 0 20.5v-15A5.51 5.51 0 0 1 5.5 0h23A5.51 5.51 0 0 1 34 5.5v15a5.51 5.51 0 0 1-5.5 5.5zM5.5 3A2.5 2.5 0 0 0 3 5.5v15A2.5 2.5 0 0 0 5.5 23h23a2.5 2.5 0 0 0 2.5-2.5v-15A2.5 2.5 0 0 0 28.5 3z"></path><path d="M13.5 26a1.5 1.5 0 0 1-1.5-1.5v-22a1.5 1.5 0 0 1 3 0v22a1.5 1.5 0 0 1-1.5 1.5zM27 11h-8a1.5 1.5 0 0 1 0-3h8a1.5 1.5 0 0 1 0 3zM27 18h-8a1.5 1.5 0 0 1 0-3h8a1.5 1.5 0 0 1 0 3z"></path></svg></div><div class="jsx-2769082546 text">Open Courses</div></a></div><div><a target="_self" class="jsx-2769082546 item" href="/community/podcast"><div class="jsx-2769082546 image"><svg height="14" xmlns="http://www.w3.org/2000/svg" width="18" viewBox="0 0 18 18"><path d="M9.415 11.077h-.369a2.777 2.777 0 0 1-2.769-2.77V2.77A2.777 2.777 0 0 1 9.047 0h.368a2.777 2.777 0 0 1 2.77 2.77v5.538a2.777 2.777 0 0 1-2.77 2.769zm5.008-7.615c.573 0 1.039.464 1.039 1.038v3.462c0 3.08-2.25 5.64-5.193 6.136v1.825h2.077a1.038 1.038 0 1 1 0 2.077h-6.23a1.038 1.038 0 1 1 0-2.077h2.076v-1.825C5.25 13.602 3 11.042 3 7.962V4.5a1.038 1.038 0 1 1 2.077 0v3.462a4.158 4.158 0 0 0 4.154 4.153 4.158 4.158 0 0 0 4.154-4.153V4.5c0-.574.465-1.038 1.038-1.038z"></path></svg></div><div class="jsx-2769082546 text">Podcast - DataFramed</div></a></div><div><a target="_self" class="jsx-2769082546 item" href="/community/chat"><div class="jsx-2769082546 image"><svg height="14" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 16"><g transform="translate(0 -1)"><path id="path-1" d="M12.595 13.364c.01-.111.02-.197.028-.251.058-.405.372-.702.74-.702h1.257c1.035-.002 1.875-.934 1.88-2.082V4.764c-.001-1.155-.842-2.092-1.878-2.094H3.38c-1.034.002-1.873.931-1.88 2.076v5.565c.001 1.156.842 2.092 1.878 2.094h6.626c.292 0 .557.189.68.484.408.977 1.07 1.576 1.94 1.85a6.004 6.004 0 0 1-.03-1.375h.001zm1.51 1.119c.048.314.136.521.235.606.566.487.258 1.497-.458 1.497-1.87 0-3.423-.785-4.33-2.51H3.376C1.513 14.07.004 12.39 0 10.311V4.74C.014 2.673 1.52 1.004 3.378 1h11.245c1.864.004 3.373 1.686 3.377 3.763v5.57c-.01 2.07-1.518 3.744-3.378 3.748h-.551c.004.138.016.273.035.402h-.001zm-8.423-5.81a1.115 1.115 0 1 0 0-2.229 1.115 1.115 0 0 0 0 2.229zm3.268 0a1.115 1.115 0 1 0 0-2.229 1.115 1.115 0 0 0 0 2.229zm3.318 0a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229z"></path></g></svg></div><div class="jsx-2769082546 text">Chat</div><div class="jsx-2769082546 statusIcon"><svg height="20" xmlns="http://www.w3.org/2000/svg" width="40" viewBox="0 0 40 17"><g fill="none" fill-rule="evenodd"><rect width="40" height="17" fill="#36D57D" rx="4"></rect><text fill="#FFF" font-family="Lato-Bold, Lato" font-size="12" font-weight="bold" letter-spacing=".4"><tspan x="5" y="13">NEW</tspan></text></g></svg></div></a></div></nav></div><div class="jsx-2769082546 section"><h5 class="jsx-2769082546">datacamp</h5><nav class="jsx-2769082546"><div><a target="_self" class="jsx-2769082546 item" href="/community/blog"><div class="jsx-2769082546 image"><svg height="14" id="Réteg_1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17 18"><path id="path-1_1_" d="M12.3 9.8s-.1.1 0 .4c.1.2.2.2-.1.5.2.2.2.3-.1.5 0 .5.1.9-.5 1-.6 0-1.4-.4-1.7.8-.2 1.1-.2.7-.2 1H5.3c.6-1.5 1-3.2 0-4-1.1-1-2.7-4.4.6-6.2.4-.2.8-.3 1.2-.4L6.9 3s1.4-.5 2.7.1v.2c.8.2 1.4.5 1.6.6.5.3 1.2.8 1.2 1.3.1.5-.5.2-.5.2.4.9.4 1.5.2 2.2-.2.7.8 1.4.7 1.9-.1.3-.5.3-.5.3m4.2-7L8.6 0h-.4L.4 2.8c-.3.1-.4.3-.4.6l1.1 10.4c0 .2.1.4.3.4l6.8 3.7c.2.1.4.1.6 0l6.6-3.7c.2-.1.3-.3.3-.4L17 3.4c-.1-.3-.2-.5-.5-.6M8.3 7c-.4 0-.7-.4-.7-.8s.3-.7.7-.7c.4 0 .7.3.7.7 0 .4-.3.8-.7.8zm2.9-1.4l.2-.1c-.3-1-1.2-1.5-1.2-1.5l-.2.2c-.1-.2-.6-.4-.7-.5l.1-.3h-.1c-.6-.3-1.3-.3-2.1 0l.4 1.1c-.6.2-1.1.7-1.1.7l-.6-.4c-.3.5-.5 1.2-.5 1.8h-.8c0 .5.1 1.4.7 2.2l.6-.4c.5.7 1.6 1.3 2.4 1.2V8.1c.3 0 .7-.1.9-.3l.4.6c.4-.1.8-1 .8-1.1l.7.2c.2-.6.2-1.3.1-1.9z"></path></svg></div><div class="jsx-2769082546 text">Official Blog</div></a></div></nav></div></div><main class="jsx-1028385822 Main"><div class="jsx-2159026896 ActionBar"><div><div class="jsx-3863678361 ActionBarSearch"><button style="font-weight:normal" class="jsx-1844558338 Button extra noPadding"><div class="jsx-1844558338 icon"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20.03 23"><path d="M10.39 19.29A9.65 9.65 0 1 1 20 9.65a9.66 9.66 0 0 1-9.61 9.64zm0-17.06a7.42 7.42 0 1 0 7.42 7.42 7.43 7.43 0 0 0-7.42-7.42z"></path><path d="M1.11 23a1.11 1.11 0 0 1-.89-1.78l4.1-5.47a1.11 1.11 0 1 1 1.78 1.34L2 22.56a1.11 1.11 0 0 1-.89.44z"></path></svg></div><div class="jsx-1844558338 desktopOnly">Search</div></button></div></div><div class="jsx-2159026896 authBlock"><div></div><div class="jsx-3196442269 ActionBarAuth"><div class="jsx-3196442269"><a href="https://www.datacamp.com/users/sign_in?redirect=https://www.datacamp.com/community" class="jsx-3196442269"><button class="jsx-1844558338 Button border minWidth"><div class="jsx-1844558338 ">Log in</div></button></a><button class="jsx-1844558338 Button primary"><div class="jsx-1844558338 ">Create Free Account</div></button></div></div></div></div><div class="jsx-1514242801 TitleBar"><div class="jsx-1514242801 filter"><button class="jsx-1844558338 Button iconButton noPadding"><div class="jsx-1844558338 icon"><svg id="Réteg_1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 7 12"><path id="path-1_1_" d="M5.9 0c.4 0 .9.3 1 .7s.1.9-.2 1.2L2.7 6l4 4.1c.3.5.3 1.1-.1 1.6s-1.1.4-1.5.1l-4.8-5c-.4-.4-.4-1.2 0-1.6L5.1.3c.2-.2.5-.3.8-.3z"></path></svg></div><div class="jsx-1844558338 desktopOnly">Back to Tutorials</div></button></div><div class="jsx-1514242801 title"><div class="jsx-3889859319 Title"><div class="jsx-3889859319 icon"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 24.22"><path d="M16.23 24.22a2 2 0 0 1-.73-.14L7 20.79a2 2 0 0 1-1.29-1.88v-4a1.5 1.5 0 0 1 3 0v3.36l7.54 2.92 7.54-2.92v-3.45a1.5 1.5 0 0 1 3 0v4.09a2 2 0 0 1-1.29 1.88L17 24.08a2 2 0 0 1-.77.14zm-.35-2.94zm.7 0z"></path><path d="M16.23 13.35a2 2 0 0 1-.62-.1C9.17 11.16 2.36 9 1.61 8.76a2 2 0 0 1-.25-3.87l14-4.78a2 2 0 0 1 1.3 0l14 4.78a2 2 0 0 1 0 3.81l-13.8 4.55a2 2 0 0 1-.63.1zm-.31-3zM5.21 6.74c3.49 1.11 9.07 2.92 11 3.56l10.68-3.53L16 3.05z"></path></svg></div><div class="jsx-3889859319 h1">Tutorials</div></div></div><div class="jsx-1514242801 action"></div></div><div class="jsx-1464850800 Tutorial"><div><div><div></div><div class="jsx-undefined social__top desktopOnly"><div class="jsx-undefined voteAndSocial"><div class="jsx-undefined"><a href="#comments" class="jsx-3293774837 CommentCounter"><span class="jsx-3293774837 icon"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 18"><path d="M12.595 13.364c.01-.111.02-.197.028-.251.058-.405.372-.702.74-.702h1.257c1.035-.002 1.875-.934 1.88-2.082V4.764c-.001-1.155-.842-2.092-1.878-2.094H3.38c-1.034.002-1.873.931-1.88 2.076v5.565c.001 1.156.842 2.092 1.878 2.094h6.626c.292 0 .557.189.68.484.408.977 1.07 1.576 1.94 1.85a6.004 6.004 0 0 1-.03-1.375zm1.51 1.119c.048.314.136.521.235.606.566.487.258 1.497-.458 1.497-1.87 0-3.423-.785-4.33-2.51H3.376C1.513 14.07.004 12.39 0 10.311V4.74C.014 2.673 1.52 1.004 3.378 1h11.245c1.864.004 3.373 1.686 3.377 3.763v5.57c-.01 2.07-1.518 3.744-3.378 3.748h-.551c.004.138.016.273.035.402zm-8.423-5.81a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229zm3.268 0a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229zm3.318 0a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229z"></path></svg></span><span class="jsx-3293774837 count">0</span></a><div class="jsx-1972554161 Upvote"><div class="jsx-1972554161"><div class="jsx-1972554161 normal"><span class="jsx-1972554161 icon"><svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 12 12"><path d="M1 10L6 0l5 10z"></path></svg></span><span class="jsx-1972554161 count">40</span></div><div class="jsx-1972554161 voted"><span class="jsx-1972554161 icon"><svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 12 12"><path d="M1 10L6 0l5 10z"></path></svg></span><span class="jsx-1972554161 count">40</span></div></div></div></div><div class="jsx-494086174 Social vertical"><div class="jsx-494086174 icons"><a href="https://www.facebook.com/sharer.php?u=https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" target="_blank" rel="noopener noreferrer" class="jsx-494086174 icon"><svg height="12" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 11.73 22.58"><path d="M7.61 22.58v-10.3h3.46l.52-4h-4V5.7c0-1.16.32-2 2-2h2.13V.16A28.47 28.47 0 0 0 8.63 0C5.56 0 3.47 1.87 3.47 5.31v3H0v4h3.47v10.3h4.14z"></path></svg></a><a href="https://twitter.com/intent/tweet?url=https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" target="_blank" rel="noopener noreferrer" class="jsx-494086174 icon centerIcon"><svg height="10" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20.42 16.67"><path d="M10 5.18c0-.28-.06-.53-.07-.78a4 4 0 0 1 .73-2.57A4.08 4.08 0 0 1 13.93 0 4 4 0 0 1 17 1.15a.43.43 0 0 0 .46.12 8.68 8.68 0 0 0 2.2-.84l.2-.1a4.36 4.36 0 0 1-1.75 2.28A9 9 0 0 0 20.42 2l-.21.3a3.83 3.83 0 0 1-.23.3A8.45 8.45 0 0 1 18.5 4a.28.28 0 0 0-.13.27A12 12 0 0 1 17 10.18a11.8 11.8 0 0 1-3.37 4.11 11.17 11.17 0 0 1-4.39 2.06 12.53 12.53 0 0 1-4.44.22 11.87 11.87 0 0 1-4.74-1.73L0 14.79a8.6 8.6 0 0 0 6.16-1.74 4.28 4.28 0 0 1-3.91-2.91h.95a6.18 6.18 0 0 0 .89-.12A4.2 4.2 0 0 1 .8 5.88a4 4 0 0 0 1.81.49 4.23 4.23 0 0 1-1.78-3A4.07 4.07 0 0 1 1.38.79 12.06 12.06 0 0 0 10 5.18z" id="iOjKBC.tif"></path></svg></a><a href="https://www.linkedin.com/cws/share?url=https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" target="_blank" rel="noopener noreferrer" class="jsx-494086174 icon"><svg height="10" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16.99 17"><path d="M3.85 17H.34V5.67h3.51zM2.07 4.18a2.09 2.09 0 1 1 2.08-2.09 2.08 2.08 0 0 1-2.08 2.09zM17 17h-3.5v-5.95c0-1.63-.62-2.54-1.91-2.54s-2.14.95-2.14 2.54V17H6.09V5.67h3.36v1.52a4 4 0 0 1 3.42-1.87c2.4 0 4.12 1.47 4.12 4.5V17z"></path></svg></a></div></div></div></div></div><div class="jsx-1464850800 preface"><div class="jsx-1464850800 author"><div class="jsx-566588255 Author"><a href="/profile/karlijn" target="_blank" class="jsx-566588255"><div style="background-image:url(https://res.cloudinary.com/dyd911kmh/image/fetch/t_avatar_thumbnail/https://assets.datacamp.com/users/avatars/000/494/311/square/Screenshot_2017-04-26_16.02.58.png?1493215479);border-radius:20px;min-width:40px;min-height:40px" class="jsx-3208234818 Avatar"></div><div class="jsx-566588255 info"><div class="jsx-566588255 name">Karlijn Willems</div><div class="jsx-566588255 date"><span>October 12th, 2016</span></div></div></a></div></div><div class="jsx-1464850800 tags"><div class="jsx-2792531181 TagLine"><div class="jsx-1764811326 Tag"><span class="jsx-1764811326 title">python</span></div><a class="jsx-1022557955 more">+<!-- -->1</a></div></div><h1 class="jsx-1464850800 pageTitle">Python For Data Science - A Cheat Sheet For Beginners</h1><div class="jsx-1464850800 description pageDescription">This handy one-page reference presents the Python basics that you need to do data science</div></div><div class="markdown"><div><p>54% of the respondents of the <a href="http://www.oreilly.com/data/free/2016-data-science-salary-survey.csp">latest O'Reilly Data Science Salary Survey</a> indicated that they used Python as a data science tool. This is a small increase in comparison to the results of the 2015 survey, where 51% of the respondents indicated to use Python. </p>

<p>Nobody can deny that Python has been on the rise in the data science industry and it certainly seems that it's here to stay.</p>

<p>This rise in popularity in the industry, the long gone infancy of Python packages for data analysis, the low and gradual learning curve and the fact that it is a fully fledged programming language are only a couple of reasons that make Python an exceptional tool for data science.</p>

<p>Although Python is a very readable language, you might still be able to use some help.</p>

<p>That's enough reason for DataCamp to make a Python cheat sheet for data science, especially for beginners. It can serve as a quick reference for those of you who are just beginning their data science journey or it can serve as a guide to make it easier to learn about and use Python.</p>

<p>This cheat sheet is free additional material that complements DataCamp's <a href="https://www.datacamp.com/courses/intro-to-python-for-data-science/">Intro to Python for Data Science course</a>, where you learn by doing.</p>

<p><a href="https://s3.amazonaws.com/assets.datacamp.com/blog_assets/PythonForDataScience.pdf" target="_blank"><img alt="Python For Data Science Cheat Sheet For Beginners" src="http://community.datacamp.com.s3.amazonaws.com/community/production/ckeditor_assets/pictures/157/content_button-cheatsheet1-2.png" style="width:401px;height:276px;" /></a></p>

<p><strong>(Above is the printable version of this cheat sheet)</strong></p>

<br />

<p>This Python cheat sheet will guide you through variables and data types, Strings, Lists, to eventually land at the fundamental package for scientific computing with Python, Numpy.</p>

<div id="scoped-content">
<style type="text/css">:target:before {
content:"";
display:block;
height:150px;
margin:-150px 0 0;
}

h3 {font-weight:normal;
}
h4 {
	font-weight: lighter;
}
table {
    width: 100%;
    table-layout: fixed;
}
td {color: black; font-size: 16px; padding-top: 2px }
th {
    height: 50px;
}
th, td {
		padding: 1.5px;
    text-align: left;}
tr:hover {background-color: #f5f5f5}
</style>
<h2>Install Python</h2>
<a href="https://www.continuum.io/downloads">Download Anaconda</a>

<h2>Libraries</h2>

<h3>Import libraries</h3>

<table>
	<tbody>
		<tr>
			<td><code>import numpy</code></td>
		</tr>
		<tr>
			<td><code>import numpy as np</code></td>
		</tr>
	</tbody>
</table>

<h3>Selective import</h3>

<table>
	<tbody>
		<tr>
			<td><code>from math import pi</code></td>
		</tr>
	</tbody>
</table>

<h2>Asking for Help</h2>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; help(str)</code></td>
		</tr>
	</tbody>
</table>

<h2>Variables and Data Types</h2>

<h3>Variable Assignment</h3>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; x=5</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; x</code></td>
		</tr>
		<tr>
			<td><code>5</code></td>
		</tr>
	</tbody>
</table>

<h3>Calculations With Variables</h3>

<table>
	<tbody>
		<tr>
			<td>Sum of two variables</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; x+2</code></td>
		</tr>
		<tr>
			<td><code>7</code></td>
		</tr>
		<tr>
			<td>Subtraction of two variables</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; x-2</code></td>
		</tr>
		<tr>
			<td><code>3</code></td>
		</tr>
		<tr>
			<td>Multiplication of two variables</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; x*2 </code></td>
		</tr>
		<tr>
			<td><code>10</code></td>
		</tr>
		<tr>
			<td>Exponentiation of a variable</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; x**2</code></td>
		</tr>
		<tr>
			<td><code>25</code></td>
		</tr>
		<tr>
			<td>Remainder of a variable</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; x%2</code></td>
		</tr>
		<tr>
			<td><code>1</code></td>
		</tr>
		<tr>
			<td>Division of a variable</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; x/float(2)</code></td>
		</tr>
		<tr>
			<td><code>2.5</code></td>
		</tr>
	</tbody>
</table>

<h3>Types and Type Conversion</h3>

<table>
	<tbody>
		<tr>
			<td>Variables to strings</td>
		</tr>
		<tr>
			<td><code>str()</code></td>
		</tr>
		<tr>
			<td><code>'5', '3.45', 'True'</code></td>
		</tr>
		<tr>
			<td>Variables to integers</td>
		</tr>
		<tr>
			<td><code>int()</code></td>
		</tr>
		<tr>
			<td><code>5, 3, 1</code></td>
		</tr>
		<tr>
			<td>Variables to floats</td>
		</tr>
		<tr>
			<td><code>float()</code></td>
		</tr>
		<tr>
			<td><code>5.0, 1.0</code></td>
		</tr>
		<tr>
			<td>Variables to booleans</td>
		</tr>
		<tr>
			<td><code>bool()</code></td>
		</tr>
		<tr>
			<td><code>True, True, True</code></td>
		</tr>
	</tbody>
</table>

<h2>Strings</h2>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; my_string = 'thisStringIsAwesome'</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string</code></td>
		</tr>
		<tr>
			<td><code>'thisStringIsAwesome'</code></td>
		</tr>
	</tbody>
</table>

<h3>String Operations</h3>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; my_string * 2</code></td>
		</tr>
		<tr>
			<td><code>'thisStringIsAwesomethisStringIsAwesome'</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string + 'Innit'</code></td>
		</tr>
		<tr>
			<td><code>'thisStringIsAwesomeInnit'</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; 'm' in my_string</code></td>
		</tr>
		<tr>
			<td><code>'True'</code></td>
		</tr>
	</tbody>
</table>

<h3>Selecting String Characters</h3>



<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; my_string[3]</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string[4:9]</code></td>
		</tr>
	</tbody>
</table>

<h3>String Methods</h3>

<table>
	<tbody>
		<tr>
			<td>String to uppercase</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string.upper()</code></td>
		</tr>
		<tr>
			<td>String to lowercase</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string.lower()</code></td>
		</tr>
		<tr>
			<td>Count String elements</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string.count('w')</code></td>
		</tr>
		<tr>
			<td>Replace String elements</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string.replace('e', 'i')</code></td>
		</tr>
		<tr>
			<td>Strip whitespace from ends</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_string.strip()</code></td>
		</tr>
	</tbody>
</table>

<h2>Lists</h2>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; a = 'is'</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; b = 'nice'</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list = ['my', 'list', a, b]</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list2 = [[4,5,6,7], [3,4,5,6]]</code></td>
		</tr>
	</tbody>
</table>

<h3>Selecting List Elements</h3>


Subset

<table>
	<tbody>
		<tr>
			<td>Select item at index 1</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list[1]</code></td>
		</tr>
		<tr>
			<td>Select 3rd last item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list[-3]</code></td>
		</tr>
	</tbody>
</table>

<h4>Slice</h4>

<table>
	<tbody>
		<tr>
			<td>Select items at index 1 and 2</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list[1:3]</code></td>
		</tr>
		<tr>
			<td>Select items after index 0</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list[1:]</code></td>
		</tr>
		<tr>
			<td>Select items before index 3</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list[:3]</code></td>
		</tr>
		<tr>
			<td>Copy my_list</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list[:]</code></td>
		</tr>
	</tbody>
</table>

<h4>Subset Lists of Lists</h4>

<table>
	<tbody>
		<tr>
			<td>my_list[list][itemOfList]</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list2[1][0]</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list2[1][:2]</code></td>
		</tr>
	</tbody>
</table>

<h3>Lists Operations</h3>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; my_list + my_list</code></td>
		</tr>
		<tr>
			<td><code>['my', 'list', 'is', 'nice', 'my', 'list', 'is', 'nice']</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list * 2</code></td>
		</tr>
		<tr>
			<td><code>['my', 'list', 'is', 'nice', 'my', 'list', 'is', 'nice']</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list2 &gt; 4</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; True</code></td>
		</tr>
	</tbody>
</table>

<h3>List Methods</h3>

<table>
	<tbody>
		<tr>
			<td>Get the index of an item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.index(a)</code></td>
		</tr>
		<tr>
			<td>Count an item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.count(a)</code></td>
		</tr>
		<tr>
			<td>Append an item at a time</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.append('!')</code></td>
		</tr>
		<tr>
			<td>Remove an item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.remove('!')</code></td>
		</tr>
		<tr>
			<td>Remove an item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; del(my_list[0:1])</code></td>
		</tr>
		<tr>
			<td>Reverse the list</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.reverse()</code></td>
		</tr>
		<tr>
			<td>Append an item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.extend('!')</code></td>
		</tr>
		<tr>
			<td>Remove an item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.pop(-1)</code></td>
		</tr>
		<tr>
			<td>Insert an item</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.insert(0,'!')</code></td>
		</tr>
		<tr>
			<td>Sort the list</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_list.sort()</code></td>
		</tr>
	</tbody>
</table>

<h2>Numpy Arrays</h2>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; my_list = [1, 2, 3, 4]</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_array = np.array(my_list)</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_2darray = np.array([[1,2,3],[4,5,6]])</code></td>
		</tr>
	</tbody>
</table>

<h3>Selecting Numpy Array Elements</h3>



<h4>Subset</h4>

<table>
	<tbody>
		<tr>
			<td>Select item at index 1</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_array[1]</code></td>
		</tr>
		<tr>
			<td><code>2</code></td>
		</tr>
	</tbody>
</table>

<h4>Slice</h4>

<table>
	<tbody>
		<tr>
			<td>Select items at index 0 and 1</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_array[0:2]</code></td>
		</tr>
		<tr>
			<td><code>array([1, 2])</code></td>
		</tr>
	</tbody>
</table>

<h4>Subset 2D Numpy arrays</h4>

<table>
	<tbody>
		<tr>
			<td>my_2darray[rows, columns]</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_2darray[:,0]</code></td>
		</tr>
		<tr>
			<td><code>array([1, 4])</code></td>
		</tr>
	</tbody>
</table>

<h4>Numpy Array Operations</h4>

<table>
	<tbody>
		<tr>
			<td><code>&gt;&gt;&gt; my_array &gt; 3</code></td>
		</tr>
		<tr>
			<td><code>array([False, False, False, True], dtype=bool)</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_array * 2</code></td>
		</tr>
		<tr>
			<td><code>array([2, 4, 6, 8])</code></td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_array + np.array([5, 6, 7, 8])</code></td>
		</tr>
		<tr>
			<td><code>array([6, 8, 10, 12])])</code></td>
		</tr>
	</tbody>
</table>

<h4>Numpy Array Functions</h4>

<table>
	<tbody>
		<tr>
			<td>Get the dimensions of the array</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_array.shape</code></td>
		</tr>
		<tr>
			<td>Append items to an array</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; np.append(other_array)</code></td>
		</tr>
		<tr>
			<td>Insert items in an array</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; np.insert(my_array, 1, 5)</code></td>
		</tr>
		<tr>
			<td>Delete items in an array</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; np.delete(my_array,[1])</code></td>
		</tr>
		<tr>
			<td>Mean of the array</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; np.mean(my_array)</code></td>
		</tr>
		<tr>
			<td>Median of the array</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; np.median(my_array)</code></td>
		</tr>
		<tr>
			<td>Correlation coefficient</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; my_array.corrcoef()</code></td>
		</tr>
		<tr>
			<td>Standard deviation</td>
		</tr>
		<tr>
			<td><code>&gt;&gt;&gt; np.std(my_array)</code></td>
		</tr>
	</tbody>
</table>

<h2>To download this cheat sheet, click below</h2>

<p><a href="https://s3.amazonaws.com/assets.datacamp.com/blog_assets/PythonForDataScience.pdf" target="_blank"><img alt="Python For Data Science Cheat Sheet For Beginners" src="https://s3.amazonaws.com/assets.datacamp.com/blog_assets/Cheat+Sheets/content_pythonfordatascience.png" style="width:401px;height:284px;" /></a></p>

<p>If you're interested in more cheat sheets, check out our <a href="https://www.datacamp.com/community/blog/bokeh-cheat-sheet-python/">Bokeh cheat sheet</a> for data visualization in Python and our <a href="https://www.datacamp.com/community/blog/python-pandas-cheat-sheet/">Pandas cheat sheet</a> for data manipulation in Python. </p>

<p>Do you want to learn more? Complete the <a href="https://www.datacamp.com/courses/intro-to-python-for-data-science/">Intro to Python for Data Science course</a> today! </p>
</div>
</div><link href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/solarized-dark.min.css" rel="stylesheet"/><link href="https://fonts.googleapis.com/css?family=Lora" rel="stylesheet"/><link href="https://fonts.googleapis.com/css?family=Roboto+Mono:400,400i,700,700i" rel="stylesheet"/></div><div class="jsx-1464850800 social__bottom mobileOnly"><div class="jsx-1464850800 voteAndSocial"><div class="jsx-1464850800"><div class="jsx-1972554161 Upvote"><div class="jsx-1972554161"><div class="jsx-1972554161 normal"><span class="jsx-1972554161 icon"><svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 12 12"><path d="M1 10L6 0l5 10z"></path></svg></span><span class="jsx-1972554161 count">40</span></div><div class="jsx-1972554161 voted"><span class="jsx-1972554161 icon"><svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 12 12"><path d="M1 10L6 0l5 10z"></path></svg></span><span class="jsx-1972554161 count">40</span></div></div></div><a href="#comments" class="jsx-3293774837 CommentCounter"><span class="jsx-3293774837 icon"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 18"><path d="M12.595 13.364c.01-.111.02-.197.028-.251.058-.405.372-.702.74-.702h1.257c1.035-.002 1.875-.934 1.88-2.082V4.764c-.001-1.155-.842-2.092-1.878-2.094H3.38c-1.034.002-1.873.931-1.88 2.076v5.565c.001 1.156.842 2.092 1.878 2.094h6.626c.292 0 .557.189.68.484.408.977 1.07 1.576 1.94 1.85a6.004 6.004 0 0 1-.03-1.375zm1.51 1.119c.048.314.136.521.235.606.566.487.258 1.497-.458 1.497-1.87 0-3.423-.785-4.33-2.51H3.376C1.513 14.07.004 12.39 0 10.311V4.74C.014 2.673 1.52 1.004 3.378 1h11.245c1.864.004 3.373 1.686 3.377 3.763v5.57c-.01 2.07-1.518 3.744-3.378 3.748h-.551c.004.138.016.273.035.402zm-8.423-5.81a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229zm3.268 0a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229zm3.318 0a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229z"></path></svg></span><span class="jsx-3293774837 count">0</span></a></div><div class="jsx-494086174 Social"><div class="jsx-494086174 icons"><a href="https://www.facebook.com/sharer.php?u=https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" target="_blank" rel="noopener noreferrer" class="jsx-494086174 icon"><svg height="12" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 11.73 22.58"><path d="M7.61 22.58v-10.3h3.46l.52-4h-4V5.7c0-1.16.32-2 2-2h2.13V.16A28.47 28.47 0 0 0 8.63 0C5.56 0 3.47 1.87 3.47 5.31v3H0v4h3.47v10.3h4.14z"></path></svg></a><a href="https://twitter.com/intent/tweet?url=https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" target="_blank" rel="noopener noreferrer" class="jsx-494086174 icon centerIcon"><svg height="10" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20.42 16.67"><path d="M10 5.18c0-.28-.06-.53-.07-.78a4 4 0 0 1 .73-2.57A4.08 4.08 0 0 1 13.93 0 4 4 0 0 1 17 1.15a.43.43 0 0 0 .46.12 8.68 8.68 0 0 0 2.2-.84l.2-.1a4.36 4.36 0 0 1-1.75 2.28A9 9 0 0 0 20.42 2l-.21.3a3.83 3.83 0 0 1-.23.3A8.45 8.45 0 0 1 18.5 4a.28.28 0 0 0-.13.27A12 12 0 0 1 17 10.18a11.8 11.8 0 0 1-3.37 4.11 11.17 11.17 0 0 1-4.39 2.06 12.53 12.53 0 0 1-4.44.22 11.87 11.87 0 0 1-4.74-1.73L0 14.79a8.6 8.6 0 0 0 6.16-1.74 4.28 4.28 0 0 1-3.91-2.91h.95a6.18 6.18 0 0 0 .89-.12A4.2 4.2 0 0 1 .8 5.88a4 4 0 0 0 1.81.49 4.23 4.23 0 0 1-1.78-3A4.07 4.07 0 0 1 1.38.79 12.06 12.06 0 0 0 10 5.18z" id="iOjKBC.tif"></path></svg></a><a href="https://www.linkedin.com/cws/share?url=https://www.datacamp.com/community/tutorials/python-data-science-cheat-sheet-basics" target="_blank" rel="noopener noreferrer" class="jsx-494086174 icon"><svg height="10" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16.99 17"><path d="M3.85 17H.34V5.67h3.51zM2.07 4.18a2.09 2.09 0 1 1 2.08-2.09 2.08 2.08 0 0 1-2.08 2.09zM17 17h-3.5v-5.95c0-1.63-.62-2.54-1.91-2.54s-2.14.95-2.14 2.54V17H6.09V5.67h3.36v1.52a4 4 0 0 1 3.42-1.87c2.4 0 4.12 1.47 4.12 4.5V17z"></path></svg></a></div></div></div></div></div></div><div id="comments" class="jsx-3956319705 PostAComment"><button class="jsx-1844558338 Button big seeAll same greyIcon"><div class="jsx-1844558338 icon"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 18"><path d="M12.595 13.364c.01-.111.02-.197.028-.251.058-.405.372-.702.74-.702h1.257c1.035-.002 1.875-.934 1.88-2.082V4.764c-.001-1.155-.842-2.092-1.878-2.094H3.38c-1.034.002-1.873.931-1.88 2.076v5.565c.001 1.156.842 2.092 1.878 2.094h6.626c.292 0 .557.189.68.484.408.977 1.07 1.576 1.94 1.85a6.004 6.004 0 0 1-.03-1.375zm1.51 1.119c.048.314.136.521.235.606.566.487.258 1.497-.458 1.497-1.87 0-3.423-.785-4.33-2.51H3.376C1.513 14.07.004 12.39 0 10.311V4.74C.014 2.673 1.52 1.004 3.378 1h11.245c1.864.004 3.373 1.686 3.377 3.763v5.57c-.01 2.07-1.518 3.744-3.378 3.748h-.551c.004.138.016.273.035.402zm-8.423-5.81a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229zm3.268 0a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229zm3.318 0a1.114 1.114 0 1 0 0-2.229 1.114 1.114 0 0 0 0 2.229z"></path></svg></div><div class="jsx-1844558338 ">Post a Comment</div></button></div></main><div class="jsx-2506565400 SidebarSocial"><div class="jsx-2506565400 rss"><a href="/community/rss.xml" class="jsx-2506565400"><svg height="13" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 18"><circle cx="3.08" cy="14.92" r="3.08"></circle><path d="M16.46 18a1.54 1.54 0 0 1-1.54-1.54c0-8.25-5.13-13.38-13.38-13.38A1.59 1.59 0 0 1 .46 1.15 1.72 1.72 0 0 1 1.54 0a16.45 16.45 0 0 1 12 4.51c3 2.95 4.51 7.08 4.51 12A1.54 1.54 0 0 1 16.46 18z"></path><path d="M10.63 18a1.54 1.54 0 0 1-1.54-1.54c0-5-2.54-7.54-7.54-7.54a1.54 1.54 0 0 1 0-3.08c6.75 0 10.63 3.87 10.63 10.62A1.54 1.54 0 0 1 10.63 18z"></path></svg>Subscribe to RSS</a></div><div class="jsx-2506565400 icons"><a href="https://www.facebook.com/pages/DataCamp/726282547396228" target="_blank" rel="noopener noreferrer" class="jsx-2506565400 icon"><svg height="16" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 11.73 22.58"><path d="M7.61 22.58v-10.3h3.46l.52-4h-4V5.7c0-1.16.32-2 2-2h2.13V.16A28.47 28.47 0 0 0 8.63 0C5.56 0 3.47 1.87 3.47 5.31v3H0v4h3.47v10.3h4.14z"></path></svg></a><a href="https://twitter.com/datacamp" target="_blank" rel="noopener noreferrer" class="jsx-2506565400 icon"><svg height="13" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20.42 16.67"><path d="M10 5.18c0-.28-.06-.53-.07-.78a4 4 0 0 1 .73-2.57A4.08 4.08 0 0 1 13.93 0 4 4 0 0 1 17 1.15a.43.43 0 0 0 .46.12 8.68 8.68 0 0 0 2.2-.84l.2-.1a4.36 4.36 0 0 1-1.75 2.28A9 9 0 0 0 20.42 2l-.21.3a3.83 3.83 0 0 1-.23.3A8.45 8.45 0 0 1 18.5 4a.28.28 0 0 0-.13.27A12 12 0 0 1 17 10.18a11.8 11.8 0 0 1-3.37 4.11 11.17 11.17 0 0 1-4.39 2.06 12.53 12.53 0 0 1-4.44.22 11.87 11.87 0 0 1-4.74-1.73L0 14.79a8.6 8.6 0 0 0 6.16-1.74 4.28 4.28 0 0 1-3.91-2.91h.95a6.18 6.18 0 0 0 .89-.12A4.2 4.2 0 0 1 .8 5.88a4 4 0 0 0 1.81.49 4.23 4.23 0 0 1-1.78-3A4.07 4.07 0 0 1 1.38.79 12.06 12.06 0 0 0 10 5.18z" id="iOjKBC.tif"></path></svg></a><a href="https://www.linkedin.com/company/datamind-org" target="_blank" rel="noopener noreferrer" class="jsx-2506565400 icon"><svg height="12" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16.99 17"><path d="M3.85 17H.34V5.67h3.51zM2.07 4.18a2.09 2.09 0 1 1 2.08-2.09 2.08 2.08 0 0 1-2.08 2.09zM17 17h-3.5v-5.95c0-1.63-.62-2.54-1.91-2.54s-2.14.95-2.14 2.54V17H6.09V5.67h3.36v1.52a4 4 0 0 1 3.42-1.87c2.4 0 4.12 1.47 4.12 4.5V17z"></path></svg></a><a href="https://www.youtube.com/channel/UC79Gv3mYp6zKiSwYemEik9A" target="_blank" rel="noopener noreferrer" class="jsx-2506565400 icon"><svg height="12" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 25.19 17.73"><path d="M24.21 1.52C23.3.44 21.62 0 18.42 0H6.78C3.5 0 1.79.47.88 1.62S0 4.4 0 6.68V11c0 4.43 1 6.68 6.78 6.68h11.64c2.78 0 4.32-.39 5.32-1.34S25.2 13.76 25.2 11V6.68c-.01-2.41-.08-4.07-.99-5.16zm-8 7.94l-5.29 2.76a.81.81 0 0 1-1.19-.72V6a.81.81 0 0 1 1.19-.72L16.17 8a.81.81 0 0 1 0 1.44z"></path></svg></a></div><div class="jsx-2506565400 menu"><a href="/about" class="jsx-2506565400 menuItem">About</a><a href="/terms-of-use" class="jsx-2506565400 menuItem">Terms</a><a href="/privacy-policy" class="jsx-2506565400 menuItem">Privacy</a></div></div><div class="jsx-879378290 BottomBar bar"><div class="jsx-879378290 barView"><div style="background-image:url(https://res.cloudinary.com/dyd911kmh/image/fetch/t_avatar_thumbnail/https://cdn.datacamp.com/community/assets/placeholder_avatar-7f673b5d40e159404a56b5931250cc73.png);border-radius:20px;min-width:40px;min-height:40px" class="jsx-3208234818 Avatar"></div><div class="jsx-879378290 blueBar">Want to leave a comment?</div></div></div></div><link href="https://fonts.googleapis.com/css?family=Lato:300,400i,400,700" rel="stylesheet"/><div class="Analytics"><script>
      ;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[];
        p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
        };p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
        n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,"script","//cdn.datacamp.com/sp/2.9.3.js","snowplow"));

      var options = {
        appId: 'community',
        platform: 'web',
        post: true,
        discoverRootDomain: true,
        contexts: {
          webPage: true,
          performanceTiming: true
        },
        forceSecureTracker: true,
        postPath: '/spevent'
      };

      window.snowplow('newTracker', 'co', 'www.datacamp.com', options);
      window.snowplow('enableActivityTracking', 10, 10);
      window.snowplow('enableLinkClickTracking');
    </script><script data-cfasync="false">(function(W,i,s,e,P,o,p){W['WisePopsObject']=P;W[P]=W[P]||function(){
      (W[P].q=W[P].q||[]).push(arguments)},W[P].l=1*new Date();o=i.createElement(s),
      p=i.getElementsByTagName(s)[0];o.async=1;o.src=e;p.parentNode.insertBefore(o,p)
    })(window,document,'script','//loader.wisepops.com/get-loader.js?v=1&site=VswVJn7o4J','wisepops');</script></div></div></div></div><div id="__next-error"></div><script>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</script><script async="" id="__NEXT_PAGE__/community/tutorial" type="text/javascript" src="/community/_next/ae82a1f0-6fdc-4b07-bd86-1be55ffe3c58/page/community/tutorial.js"></script><script async="" id="__NEXT_PAGE__/_error" type="text/javascript" src="/community/_next/ae82a1f0-6fdc-4b07-bd86-1be55ffe3c58/page/_error.js"></script><script type="text/javascript" src="/community/_next/163c3423841a38b05eb7fe05a92d006a/app.js" async=""></script></body></html>